カテゴリー: google

Adobe AIR HTMLLoaderでGoogle Maps JavaScript API(バージョン3.28.7)が使えなくなった。>>フローズンバージョン(v=3.20)指定で表示できた。

デジタルサイネージの施設情報で利用しているGoogleMapが表示されなくなったと。
構成は
-Windows7
-AdobeAIR : 3.なんとか。
-Gogolemap: v3(指定なし)

とりあえずフローズンバージョン(v=3.20)指定で表示できました。

<script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?key={YOUR_API_KEY}&v=3.20"></script>

バージョニング
https://developers.google.com/maps/documentation/javascript/versions?hl=ja

バージョンが最新バージョン、リリースバージョン、フローズンバージョン3つしか無く
どんどん新しいものに変わっていくらしいので、将来的にはダメダメそう(AIRがふるいWebkitなので。。

早くElectronなどに変更したほうがよいのかも。

googleAnalyticsでリンククリック時のトラッキング[google]

ボタンにonClick属性をつけてトラッキングする。
(hogehoge部分は任意の仮想URL)


<a onClick="_gaq.push(['_trackPageview','/hogehoge']);" href="xxxx.mp3" target="_blank">

Powered by WordPress & Theme by Anders Norén